皮皮狗博客皮皮狗博客

欢迎光临
我们一直在努力

php2.6和php7.1兼容

location ~ [^/]\.php(/|$)
    {
        if ($request_uri ~*  "renren_shop"){
          fastcgi_pass unix:/tmp/php-cgi-71.sock;
        }
      fastcgi_pass  unix:/tmp/php-cgi-56.sock;
      fastcgi_index index.php;
      include fastcgi.conf;
      include pathinfo.conf;
    }

图片

2.开始配置

  • 修改nginx配置文件
    宝塔站点管理点击您想配置的站点,选择配置文件,我们先将指向的33行前加#注释掉然后加入如下代码

location ~ [^/]\.php(/|$)
    {
        if ($request_uri ~*  "renren_shop"){
          fastcgi_pass unix:/tmp/php-cgi-71.sock;
        }
      fastcgi_pass  unix:/tmp/php-cgi-56.sock;
      fastcgi_index index.php;
      include fastcgi.conf;
      include pathinfo.conf;
    }


3.修改完前后对比

  • 修改前:

php2.6和php7.1兼容(图1)

  • 修改后:

php2.6和php7.1兼容(图2)


4.保存

点击保存按钮,如果保存后出现错误提示,证明没有正确粘贴代码,或者之前的没有注释掉。


未经允许不得转载:皮皮狗博客 » php2.6和php7.1兼容
分享到: 更多 (0)

某某博客 带给你想要内容

联系我们